This project has moved. For the latest updates, please go here.

Form based authentication FBA - keeps getting “Make sure your user name and password are correct”

Sep 13, 2016 at 5:51 PM
I am getting this error “Make sure your user name and password are correct”, also when I created a new user in the database, I am getting access denied error.

The providers were configured for SP 2007, Now I am configuring the same provider in SP2010.
Coordinator
Sep 13, 2016 at 6:10 PM
I think there's something wrong with your FBA configuration. My guess would be that the app pool user for SharePoint (and different app pools may have different users) doesn't have DBOwner rights on the aspnetdb database.
Sep 13, 2016 at 6:14 PM
The same configuration with the same database was working when I created a Test 2007 Environment.
Coordinator
Sep 13, 2016 at 6:20 PM
Are all the app pools running as the same domain users as the 2007 environment though? Check it in IIS.

If the user has permissions to the db, i'd double check all of the config files. (Note that FBA setup for 2010 is different than 2007, as it now goes through an intermediary Claims Based Authentication service). You can check that everything was setup properly by following the tutorial here:

http://blogs.visigo.com/chriscoulson/configuring-forms-based-authentication-in-sharepoint-2013-part-1-creating-the-membership-database/

The tutorial is for 2013, but everything is the same for 2010 EXCEPT the version number on the web config entries (2010 is .net 2.0, 2013 is .net 4.0).
Sep 13, 2016 at 6:22 PM
Thank for all your help, I will look over these articles and your suggestions and will get back with the results.

Thanks again @ccoulson
Sep 29, 2016 at 1:22 AM
I configured everything from scratch using the article you mentioned. But I am getting the same error, “Make sure your user name and password are correct".
Coordinator
Sep 29, 2016 at 2:24 AM
Are you still getting the access denied error still when trying to create a new user? I'd double check everything, and also check the SharePoint log file then and see if there is anything that might give you a hint as to what is going on there. As for the error “Make sure your user name and password are correct", I'd double check the web.config file for the SecurityTokenService - as it's that config that is used to authenticate the user (the local web.config or the machine.config are used once you've logged in).
Coordinator
Sep 29, 2016 at 2:25 AM
Are you still getting the access denied error still when trying to create a new user? I'd double check everything, and also check the SharePoint log file then and see if there is anything that might give you a hint as to what is going on there. As for the error “Make sure your user name and password are correct", I'd double check the web.config file for the SecurityTokenService - as it's that config that is used to authenticate the user (the local web.config or the machine.config are used once you've logged in).
Sep 29, 2016 at 2:31 AM
The aspnetdb is from MOSS 2007. Will that be causing the problem?


I will check everything once again
Coordinator
Sep 29, 2016 at 2:34 AM
No - the databases are identical between 2007 and 2010. It's just the setup that's different - particularly the web config changes (part 3 of the tutorial) and the need to configure the claims based settings in SharePoint (part 4 of the tutorial).
Oct 19, 2016 at 6:58 PM
Hi,

I created new user in the aspnet database, I was getting access denied error for this user and this “Make sure your user name and password are correct" error for the OLD USERS.

I changed the password format for one of the OLD USER to 1(hashed) and copied the password and password salt from NEW USER and I was able to login and navigate the site.

I am not sure why this is the issue.

Also I do not see the users in the people picker.
Coordinator
Oct 20, 2016 at 10:22 AM
What was the password format before? If it was 'Encrypted', you'll have to make sure that you have the same MachineKey in your web.config as the web.config that was used when the passwords were saved. If you don't have it, you'll have to reset everybody's password, either using the FBA Pack's Reset Password mechanism or Password Recovery web part, or using the technique you used above.

As for the people picker, did you adjust the PeoplePickerWildcards settings in the web.config? I never touch it and the people picker works for me.
Oct 20, 2016 at 6:12 PM
Yes I made changes to the PeoplePickerWildCards in both Central Admin config and Web Application config, I did not found PeoplePickerWildcards in Security Token config and Machine config.

I added both thee role provider key as well as membership provider key to the PeoplePickerWildcards.
Coordinator
Oct 20, 2016 at 6:14 PM
Maybe try just reverting the peoplepickerwildcards section back to the default (either from a backed up web.config, or create a new web application and look at that web.config).