This project has moved. For the latest updates, please go here.

Error Loading and Running Event Receiver

Oct 17, 2013 at 11:00 PM
We are running the FBA Pack version 1.3.1 and have un-deployed it and re-deployed it several times. We cannot escape event ID 6875. We have a critical document library that a lot of people are working in and are being plagued with check in/check out issues. I cannot pinpoint the issue, but see this in my event log several times each minute:

Error loading and running event receiver Visigo.Sharepoint.FormsBasedAuthentication.MembershipReviewHandler in Visigo.Sharepoint.FormsBasedAuthentication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9dba9f460226d31d. Additional information is below.

: Column '_Status' does not exist. It may have been deleted by another user. /NWG/FNIHBCKSP

The status column is there so I don't know why it says its not. I have seen other posts on this site about this issue and the solution was to either install the latest version of the FBA Pack or re-deploy it. Not working for me. Any ideas?

Thank you,

James
Coordinator
Oct 18, 2013 at 4:28 AM
Have you tried deactivating and reactivating the Forms Based Authentication Management feature in the site collection? When you do that it recreates the Membership Review List, which was causing the issues. You may want to try deleting the Membership Review List and then Deactivating/Reactivating and make sure that it gets recreated.

Another possibility is that the FBA Pack has been activated in multiple site collections - Make sure that the reactivation happens in all site collections (maybe you have some test site collections?) as any could be causing it. The deployment script should have taken care of the deactivation/reactivation on all site collections - but if that didn't run against everything or didn't run properly for some reason, that could be why you're experiencing the issue.
Oct 18, 2013 at 7:07 PM
Thank you for your response. I have now deactivated and reactivated it at the Site Collection level and am testing. I'll post back by tomorrow with the result.
Oct 18, 2013 at 7:37 PM
The errors are still there. I have done the following:

Removed the Status column from the "Core Document Columns" and can see the correct status column in the membership review list.
Removed the FBA pack (retracted) from test web applications
Deactivated and Reactivated the FBA Pack at the site collection level again after all else was done.

When I check out a document, and then check it back in, two instances of event 6875 are created in the event log due to the check in process:

Error loading and running event receiver Visigo.Sharepoint.FormsBasedAuthentication.MembershipReviewHandler in Visigo.Sharepoint.FormsBasedAuthentication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9dba9f460226d31d. Additional information is below.

: Column '_Status' does not exist. It may have been deleted by another user. /NWG/FNIHBCKSP

It references the correct sub-site and document library. "NWG/FNIHBCKSP"

I will go through the reactivate process in all site collections now and report back.
Oct 18, 2013 at 7:38 PM
I should mention I am running SharePoint Foundation 2010 Service Pack 2 without further CU installs.
Nov 8, 2013 at 1:20 AM
This problem is still hitting us hundreds of times a day but in only one web application.
When someone uses any document library and checks in a document, this event 6875 occurs. I have retracted the FBA Pack solution, disabled the Forms Based Auth feature at the Site Collection level, removed all Membership Review Lists (from all web applications), re-enabled Forms Based Auth feature, and redeployed the FBA Pack, but still see the error with every check in.
Please help.

Error - : Column '_Status' does not exist. It may have been deleted by another user. /SAFET/CC

Why does the error specifically mention the '_Status' column? I can see a status column in the membership review list, and in my libraries that are causing this error. Is the error referring to the status column in the review list or the library the error occurred in?


Thank you in advance.
Coordinator
Nov 8, 2013 at 4:27 AM
It looks like it's complaining because the event receivers on the membership review list are being called by a list that where the status column does not exist. (The event receiver depends on this status column). The event receiver should only be called from the membership review list - which should have this column, so you shouldn't get the error. However there was a bug in an earlier version of the fba pack where the way it was getting deployed was causing it to be called from several lists. This is fixed in the latest version though, so i'm not sure why you're getting the error unless you're running an older version of the FBA Pack. You can double check the version installed from the FBA Site Configuration page.

If you undeploy the FBA Pack from this web application, do the errors stop?
Nov 8, 2013 at 6:23 PM
Here is the version info from the Site Configuration page: Sharepoint 2010 FBA Pack 1.3.1.0

After retracting the solution from all site collections, the errors have stopped but there are references to the assembly occurring. Event 6875 only hit when someone would check in a file, so I retracted the solution and checked out a file and then checked it back in. I got event 6644 instead of 6875.

Event 6644 - Event manager error: Could not load file or assembly 'Visigo.Sharepoint.FormsBasedAuthentication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9dba9f460226d31d' or one of its dependencies. The system cannot find the file specified.
Nov 8, 2013 at 8:01 PM
I can see in SQL that I have 4 copies of the event receiver stuck in a web application. I will retract the solution form the server, delete any orphaned event receivers, repair SharePoint, and then reinstall the FBA pack. Will let you knowhow that goes.
Nov 8, 2013 at 9:34 PM
I cannot seem to delete the event receivers. Errors have returned after the repair and redeploy. Any help would be a great thing.
Coordinator
Nov 8, 2013 at 10:58 PM
Very strange that the event receivers are still there after removing the FBA Pack. Also strange that there are multiple event receivers - there should just be one on the membership request list. I can see the event receivers getting attached to other lists if at one point you had an earlier version of the FBA Pack, but i'm surprised they didn't get removed when the FBA Pack was retracted.

To remove the event receivers, you will have to find the lists that have the event receivers attached to them. Have you tried the following to delete the event receivers:

http://devinthefastlane.wordpress.com/2012/10/05/add-remove-event-receivers-to-list-content-types-in-sharepoint-with-powershell/

?
Coordinator
Feb 25, 2015 at 11:13 PM
I've added an issue for cleaning up these orphaned event receivers with the deployment script:

https://sharepoint2010fba.codeplex.com/workitem/862