Issue With Full Name getting changed to Claims format

Nov 6, 2012 at 4:27 AM
Edited Nov 6, 2012 at 4:31 AM

Hi,

This issue plays out as follows. User is created doesn't matter if they register or I create them. Everything looks fine in the Manage Users Screen. The created user logs in, and everything is still ok. Once the user clicks on My Profile the Full Name changes to the claims format. This happens to the profile full name as well as the FBA membership screen also the email address does not show up under the profile. Can anyone help with this. I am not sure where to start with this,

 

Thanks,

Chris

Coordinator
Nov 6, 2012 at 2:00 PM

The issue is because the My Profile page is stored in a separate site collection. The full name is stored on the user's profile in each SharePoint site collection.  When you move between site collections, this profile information doesn't carry over and has to be re-entered in each site collection.  This works for AD users, because SharePoint includes a user synchronization process for AD users, but it doesn't have one for FBA users.  I've raised an issue to address this in a future version of the FBA Pack:

http://sharepoint2010fba.codeplex.com/workitem/825

Nov 17, 2012 at 2:08 PM

Hi Chris

Thanks for the reply. My question is given that the profiles are in different site collections why does the claims format overwrite the FBA full name in the main site collection? The full names under the FBA user management gets changed to the claims format as soon as the user goes to the my profile site

 

Thanks,

 

Chris 

Coordinator
Nov 19, 2012 at 1:23 PM

Oh, so on the main site collection - where the full name has been set correctly - it changes back to the claims format as soon as you go to the my profile site? That is strange.  Do you have the latest version of the FBA Pack (1.3.1)? You can check the version from the FBA Site Configuration page. If there is no version on the site configuration page, you have a version < 1.3.  Older versions of the FBA Pack had a bug where changes to lists in the site collection could trigger the full name being reset.

If you have the latest version of the fba pack, cause the name to be reset by clicking on My Profile, and then check the SharePoint log files to see if any errors/exceptions occur that might give us a hint as to what's happening.