Negotiate

Jan 24, 2012 at 1:55 PM

I have tried everything I could think of - evertyime i try to run the deploy command I get an error as follows:

Going to enable Feature
Enable-SPFeature : The HTTP request is unauthorized with client authentication
scheme 'Negotiate'. The authentication header received from the server was 'NTL
M'.
At C:\SharePoint2010FBAPack.1.2.0\Deploy.ps1:56 char:17
+ Enable-spfeature <<<<  -identity $featureName -confirm:$false -url $url
    + CategoryInfo          : InvalidData: (Microsoft.Share...etEnableFeature:
   SPCmdletEnableFeature) [Enable-SPFeature], MessageSecurityException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe
   ature

I have checked and from what I cna see all of the websites are NTLM. Please help.

Thanks,

Mike

Coordinator
Jan 24, 2012 at 2:06 PM

Did you pass a url to the deploy command for the site collection you want to activate it on? From the error message it looks like the url to the site collection was probably invalid.  No worries though - this step simply activates the feature on the specified site collection.  If there were no errors up to this step, then the FBA pack has been deployed to all your web applications.  You now simply have to activate the FBA Pack feature on whichever site collections you like.  You can do this manually on each site collection by going to Site Settings -> Site Collection Features.

Jan 24, 2012 at 2:12 PM

I did specify the url. My exact command was:

 .\deploy http://XXX/ (XXX is my site name). When I try to manually activate iget the following error:

Error

An unexpected error has occurred.

 

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: 910a56ef-1ac2-47aa-b52f-6ab9e0e8f920

Date and Time: 1/24/2012 10:12:13 AM

 

 

Coordinator
Jan 24, 2012 at 2:21 PM

That's interesting. Check the SharePoint log for the correlation id to see what the exact error is. You should probably also check central admin - Manage Farm Solutions to see if it shows the solution properly deployed to the web apps.

Jan 24, 2012 at 2:43 PM

CA states that the solution is in fact deployed to the website.

 

Jan 24, 2012 at 2:48 PM

I think I may know why I got the error, but not how to solve it.  If I go to Site Settings -> Site Collection Features, it takes me to the CA site (not my port 80 site.) I can't seem to get to my port 80 site. If I try to enter it in IE, I get an error that the website cannot display the page. I can't find a way to get to the site so I can activate the feature.

 

Coordinator
Jan 24, 2012 at 2:49 PM

Good. What did the error in the log say?

One thing to make sure of - the user you're logged in as when running the deploy command should be a site collection administrator on the site collection.

Coordinator
Jan 24, 2012 at 2:52 PM

Ok - that makes sense that if you can't access the site collection, the feature can't be enabled. Check under Web Application management in central admin the web apps that are defined, and make sure that one really is defined on port 80 (new web apps do not default to port 80). Make sure there's a site collection created on the web application. And make sure that there is a site in IIS that matches the web app, and that the site and it's app pool are started.

Jan 24, 2012 at 3:29 PM

Event manager error: Could not load file or assembly 'Visigo.Sharepoint.FormsBasedAuthentication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9dba9f460226d31d' or one of its dependencies. The system cannot find the file specified.

 

Jan 24, 2012 at 4:20 PM

Should the web application be set to Claims Based Authentication prior to running this process, or does it take care of that for you?

 

Coordinator
Jan 24, 2012 at 4:39 PM

It should be set to claims based FBA first, here's a guide:

http://donalconlon.wordpress.com/2010/02/23/configuring-forms-base-authentication-for-sharepoint-2010-using-iis7/

Jan 24, 2012 at 5:01 PM

The guide you linked to covers a lot more than setting claims based authentication. I assume I should only do that item and not all of the rest?

Coordinator
Jan 24, 2012 at 5:07 PM

It also details how to configure the membership providers and membership database. If you've already done that, you can skip it - but they are required for forms based authentication.

Jan 24, 2012 at 5:19 PM

I am aware they are needed. I have been to this site and have followed thisset of steps exactly and I run into problems about half way through. I end up with either an error telling me that my provider is not authorized and needs to be added to the GAC, or an error 26 or an error 40. I was hoping your program did all of the set up, added the connection string, the role and member providers etc. So where does your program pick up in the process?

Coordinator
Jan 24, 2012 at 5:21 PM

It doesn't do any of that. FBA has to be completely configured first to use it. It adds the pieces that SharePoint leaves out - a management interface for FBA users and groups, and web parts that allow users to register, recover their password and change their password.

Jan 24, 2012 at 5:56 PM

OK. Is there a codeplex application that you know of that will set up and configure the FBA for you?

Coordinator
Jan 24, 2012 at 6:04 PM

Not that I know of.

Jan 24, 2012 at 6:05 PM

OK, and THANKS A LOT for all of the time you took to answer all of my questions!!!! I certainly appreciate it.

Coordinator
Jan 24, 2012 at 6:09 PM

No problem. If you do need help configuring things, I do offer an FBA Pack support plan that would cover that. I could help you configure it over the phone and via screen sharing.

http://www.visigo.com/purchase.html