This project has moved. For the latest updates, please go here.

Creating Membership Successfully but not receiving email.

May 31, 2011 at 8:46 AM
Edited May 31, 2011 at 11:57 AM

Creating Membership Successfully but not receving email.Previously when i create user i use to get mails but now am not getting.What might be the reason.Please Suggest me.

Thanks

Coordinator
May 31, 2011 at 11:58 AM

My guess would be the email setup. Make sure things are properly configured in Central Admin. Also check the smtp server that's configured and make sure that you can send email's through it from that server. Use telnet from the SharePoint server to test: http://exchange.mvps.org/smtp_frames.htm.

May 31, 2011 at 12:05 PM

Hi ccoulson previously i would get mail but suddenly it stopped receiving mail.How should i use this telnet.

Coordinator
May 31, 2011 at 12:09 PM

Just follow the instructions in the link.  Here's another one:

http://www.yuki-onna.co.uk/email/smtp.html

If you google "telnet smtp" there's lots of help pages.

Jul 13, 2011 at 8:53 PM

Now, After creating membership receiving emails for internal users. But data is not getting updated in MembershipReview List. 

Coordinator
Jul 14, 2011 at 1:49 AM

Another person reported the users not having sufficient permissions to post to the membership review list:

http://sharepoint2010fba.codeplex.com/discussions/261249

I haven't had any problems with a default SharePoint installation, but maybe you have some customized permissions that are blocking access?  

Jul 27, 2011 at 7:26 PM

After making changes for anonymous users, receiving emails for internal users, but not for the out of domain users. What setting do I need to do with SharePoint? 

Coordinator
Jul 27, 2011 at 10:26 PM

No changes to SharePoint.  It sounds like you don't have relaying setup on your SMTP server.  You'll have to allow relaying from emails coming from your SharePoint server.  There's some information here:

http://technet.microsoft.com/en-us/library/cc288949.aspx

Aug 2, 2011 at 7:08 PM

In Membership webpart, I dont want the fields Security Question and Answer. How can I remove those fields from the webpart? 

Coordinator
Aug 2, 2011 at 7:18 PM

They show based on your membership provider settings. You'll need to set RequiresQuestionAndAnswer to false in your web.config:

http://msdn.microsoft.com/en-us/library/system.web.security.sqlmembershipprovider.requiresquestionandanswer.aspx

Aug 4, 2011 at 6:54 PM

Thanks for reply. Solution worked.

I have added some fields to the membership webpart like verifyemail, Phone, Extension. VerifyEmial should be after Email, but its coming before Email. I want to set Email field prior to the VerifyEmail field. How can I do that?

Also, I have one welcome page and it two links for Requester's signin and Arbitrators Signin. When user clicks on Requester's signin, his role should set to Requester in database and same with Arbitrator. Database is extended for the requirement. Where can I make these changes?

Please give me suggestions on both questions.

Thanks,

 

Coordinator
Aug 4, 2011 at 10:52 PM

I assume you're talking about the Membership Request web part.  To rearrange the controls, you're going to want to look at the CreateUserStep property - it contains the template for the control.  There's a bit of info here (although it focuses on using the GUI instead of code):

http://www.4guysfromrolla.com/articles/050609-1.aspx

I'm going to assume by signin, you mean register? I would think maybe you'd have two different registration pages, but just one login page - then the user that logs in gets the permissions assigned to them.  If that's the case, it's pretty straight forward - just create two registration pages and put a membership request web part on each.  For one, set the default group to 'Requesters', for the other set the default group to 'Arbitrator'.

Aug 8, 2011 at 7:08 PM

Regarding Setting the roles: By signing in the context of creating new user. I have one welcome page having 2 links "Arbitrators" and "Requesters". When user will click on Arbitrators the page having Membership Request WebPart will show up and when click on Create button, the user role should set to Arbitrator in database. Same things will happen with Requesters, webparts are same for both(Membership Request). If I will set the default group to Requesters'/'Arbitrators', it will not save in database, and so will not be able to use in report generation or so.....

Any Suggestions will be helpful.

Thanks,

 

Coordinator
Aug 9, 2011 at 3:42 AM

Yes, unfortunately currently you can only select SharePoint groups, not membership roles, when creating a user.  I think you may have to modify the MembershipRequest to update the membership user.  Maybe either add them to a role, or populate the MembershipUser comment property.

Aug 9, 2011 at 8:52 PM

OK. About rearranging Fields on the Webpart: I couldnt rearrange the Email field from the webpart. Is there any other way to rearrange fields?

Thanks, 

Coordinator
Aug 9, 2011 at 9:04 PM

At the moment you'll have to do it by programmatically adding controls to the ContentTemplateContainer of the CreateUserStep property.  In the future i'm thinking of adding the templates to the web parts, so this will be easier to do.