No items to show - UserDisp.aspx

Mar 17, 2014 at 5:01 PM
Hi all,

I've noticed on one of my installs of FBA that the /_layouts/FBA/Management/UsersDisp.aspx is currently saying there are no items to show in this view.

Any ideas why this couldn't display? FBA users can login so I'd need to know what this page connects to and which service would this use as we've changed some of our service accounts recently.

Thanks!
Coordinator
Mar 17, 2014 at 7:28 PM
It comes from the membership database, joined up with the existing SharePoint user profiles. If none are showing up, it's likely there's a misconfiguration in your membership provider or possibly your SharePoint web app.

The membership configuration for logging in actually comes from a different place than what's used once you're logged in.

Logging in, it uses the membership provider defined in the SecurityTokenService.

Once the user is logged in, it uses the membership config from the web.config for the SharePoint web application itself (which also inherits the settings for the machine.config if your membership settings are defined there).

In Central Admin, check which membership provider is being used:
Manage Web applications -> select the web application -> Authentication Providers. The name of the membership provider defined there should match what's defined in the SecurityTokenService web.config, which should also match what's defined for your web application web.config.
Mar 18, 2014 at 1:47 PM
Thanks for the info, it was the web app that had changed service account which I've now switched back.

I'm assuming, I need to give the new account access to the membership database in order for it to work?
Coordinator
Mar 18, 2014 at 2:58 PM
You do.
Mar 18, 2014 at 4:38 PM
Thanks!