This project has moved. For the latest updates, please go here.

Deployed FBA Pack but couldn't see the web parts

Mar 14, 2013 at 7:44 AM
Hi,

I couldn't find the three web parts shown in the screenshot: Membership Request, Change Password and Password Recovery that I have to manually add to the page .

The wsp file has been deployed successfully.

In addition, the functions under the Users and Permissions are not visible as well.

Would appreciate some advise on this. Thanks!

Thanks,
Angie
Mar 14, 2013 at 7:58 AM
Hi,

I have also tried to deploy using the instructions but here are my errors in powershell:

Execution Policy Change
The execution policy helps protect you from scripts that you do not trust.
Changing the execution policy might expose you to the security risks described
in the about_Execution_Policies help topic. Do you want to change the execution
policy?
[Y] Yes [N] No [S] Suspend [?] Help (default is "Y"): y
PS C:\Users\connectadmin\Desktop\SharePoint2010FBAPack.1.3.1> .\deploy http://ha lla:8080 Going to uninstall feature Going to uninstall solution Waiting for job to finish Waiting to finish job solution-deployment-visigo.sharepoint.formsbasedauthentica
tion.wsp-0.......Finished waiting for job..
Going to remove solution
Remove-SPSolution : The solution "visigo.sharepoint.formsbasedauthentication.ws
p" has been deployed in the farm. Please retract the deployment before removing
the solution.You can also use the -override parameter to forcibly remove the s
olution, but you will not be able to retract the solution deployment.
At C:\Users\connectadmin\Desktop\SharePoint2010FBAPack.1.3.1\UnDeploy.ps1:68 ch
ar:19
  • Remove-SPSolution <<<< -identity $solutionName -confirm:$false
    • CategoryInfo : InvalidData: (Microsoft.Share...tRemoveSolution:
      SPCmdletRemoveSolution) [Remove-SPSolution], SPException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletRemoveSo
      lution
Going to add solution
Add-SPSolution : A solution with the same name "visigo.sharepoint.formsbasedau
thentication.wsp" or id "956715d5-f34c-4b00-bfb7-8c35d5fa0f62" already exists i
n the solution store.
At C:\Users\connectadmin\Desktop\SharePoint2010FBAPack.1.3.1\Deploy.ps1:63 char
:15
  • Add-SPSolution <<<< $solutionPath
    • CategoryInfo : InvalidData: (Microsoft.Share...dletAddSolution:
      SPCmdletAddSolution) [Add-SPSolution], ArgumentException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletAddSolut
      ion
Going to install solution to all web applications
Waiting for job to finish
Waiting to finish job solution-deployment-visigo.sharepoint.formsbasedauthentica
tion.wsp-0....Finished waiting for job..
Deactivating/activating active features to ensure activation script is run
Get-SPFeature : Cannot find a Feature object with Path or Id: FBAManagement in
scope Local farm.
At C:\Users\connectadmin\Desktop\SharePoint2010FBAPack.1.3.1\Activate.ps1:3 cha
r:26
  • $feature = Get-SPFeature <<<< $featureName
    • CategoryInfo : InvalidData: (Microsoft.Share...mdletGetFeature:
      SPCmdletGetFeature) [Get-SPFeature], SPCmdletPipeBindException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletGetFeatu
      re
Cannot find an overload for "QueryFeatures" and the argument count: "1".
At C:\Users\connectadmin\Desktop\SharePoint2010FBAPack.1.3.1\Activate.ps1:4 cha
r:94
  • $features = [Microsoft.SharePoint.Administration.SPWebService]::ContentSe
    rvice.QueryFeatures <<<< ($feature.id)
    • CategoryInfo : NotSpecified: (:) [], MethodException
    • FullyQualifiedErrorId : MethodCountCouldNotFindBest
Deactivating/Activating Feature FBAManagement on
Disable-SPFeature : The Feature is not found. Provide a Guid and -Force paramet
er then try again.
At C:\Users\connectadmin\Desktop\SharePoint2010FBAPack.1.3.1\Activate.ps1:8 cha
r:20
  • Disable-spfeature <<<< -identity $featureName -confirm:$false -url $
    feature.Parent.Url
    • CategoryInfo : InvalidData: (Microsoft.Share...tDisableFeature:
      SPCmdletDisableFeature) [Disable-SPFeature], SPCmdletException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletDisableF
      eature
Enable-SPFeature : The Feature is either not found or not a Farm Level Feature.
Use Url parameter to specify the scope of the Feature.
At C:\Users\connectadmin\Desktop\SharePoint2010FBAPack.1.3.1\Activate.ps1:9 cha
r:19
  • Enable-spfeature <<<< -identity $featureName -confirm:$false -url $f
    eature.Parent.Url
    • CategoryInfo : InvalidData: (Microsoft.Share...etEnableFeature:
      SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe
      ature
Going to enable Feature
Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in
a Site level defined by the Url http://default:8080.
At C:\Users\connectadmin\Desktop\SharePoint2010FBAPack.1.3.1\Activate.ps1:29 ch
ar:18
  • Enable-spfeature <<<< -identity $featureName -confirm:$false -url $url
    • CategoryInfo : InvalidData: (Microsoft.Share...etEnableFeature:
      SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe
      ature
Coordinator
Mar 14, 2013 at 4:24 PM
It's hard to tell in the printout what you used for the url to deploy it to, but it looks like there was a space in the url. That could be causing your problems. The url you use should be the url to the site collection you want to activate it on (and there shouldn't be any spaces in the url).

If you continue to experience problems deploying, simply run:
.\deploy

which will deploy the solution, but not activate it on a site collection. After the deploy succeeds, you will have to login to the site collection as a site administrator and go to 'Site Settings -> Site Collection Features' and activate the Forms Based Authentication Management feature. After the feature is activated, you should be able to see the web parts and Users and Permissions menu items.
Jul 4, 2013 at 4:14 AM
Has anyone got to the bottom of this problem? I just tried to deploy this solution and got

PS C:\temp\visigo> .\deploy http://CEODEVSP2010.ceo.net:8001/
Solution not installed
Going to add solution

Name SolutionId Deployed

visigo.sharepoint.formsbase... 956715d5-f34c-4b00-bfb7-8c35d5fa0f62 False
Going to install solution to all web applications
Waiting for job to finish
Waiting to finish job solution-deployment-visigo.sharepoint.formsbasedauthentic
tion.wsp-0..Finished waiting for job..
Deactivating/activating active features to ensure activation script is run
Get-SPFeature : Cannot find a Feature object with Path or Id: FBAManagement in
scope Local farm.
At C:\temp\visigo\Activate.ps1:3 char:26
  • $feature = Get-SPFeature <<<< $featureName
    • CategoryInfo : InvalidData: (Microsoft.Share...mdletGetFeature:
      SPCmdletGetFeature) [Get-SPFeature], SPCmdletPipeBindException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletGetFeatu
      re
Cannot find an overload for "QueryFeatures" and the argument count: "1".
At C:\temp\visigo\Activate.ps1:4 char:94
  • $features = [Microsoft.SharePoint.Administration.SPWebService]::ContentSe
    rvice.QueryFeatures <<<< ($feature.id)
    • CategoryInfo : NotSpecified: (:) [], MethodException
    • FullyQualifiedErrorId : MethodCountCouldNotFindBest
Deactivating/Activating Feature FBAManagement on
Disable-SPFeature : The Feature is not found. Provide a Guid and -Force paramet
er then try again.
At C:\temp\visigo\Activate.ps1:8 char:20
  • Disable-spfeature <<<< -identity $featureName -confirm:$false -url $
    feature.Parent.Url
    • CategoryInfo : InvalidData: (Microsoft.Share...tDisableFeature:
      SPCmdletDisableFeature) [Disable-SPFeature], SPCmdletException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletDisableF
      eature
Enable-SPFeature : The Feature is either not found or not a Farm Level Feature.
Use Url parameter to specify the scope of the Feature.
At C:\temp\visigo\Activate.ps1:9 char:19
  • Enable-spfeature <<<< -identity $featureName -confirm:$false -url $f
    eature.Parent.Url
    • CategoryInfo : InvalidData: (Microsoft.Share...etEnableFeature:
      SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe
      ature
Going to enable Feature
Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in
a Site level defined by the Url http://CEODEVSP2010.ceo.net:8001/.
At C:\temp\visigo\Activate.ps1:29 char:18
  • Enable-spfeature <<<< -identity $featureName -confirm:$false -url $url
    • CategoryInfo : InvalidData: (Microsoft.Share...etEnableFeature:
      SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe
      ature
Coordinator
Jul 4, 2013 at 5:30 AM
Is the url you're pointing to Central Admin? If that's the case, that's not supported. You can only deploy to standard site collections.

If you continue to have issues, you may want to try the deploy without the url:
./deploy

That will deploy it to all web applications, but will not activate it anywhere. You will have to go to the site collection you'd like to use it in and activate it in the Site Collection Features.
Jul 4, 2013 at 6:05 AM
The url that it is pointing to is an extranet on port 8001. I can log into it using either FBA or Windows Authentication. So I'm sure that I have FBA working.

I must have missed the step to activate in Site Collection Features. It all seems to be good now. Well I can see it. Thanks for your help.