Membership Request List is always empty

Oct 29, 2012 at 11:31 PM

I had a Shared Hosted environment and had them install this web part...but never got any of the requests to show up in the Review Membership Request list???  I have since purchased my own server, installed Windows 2008 R2 and SharePoint Foundations and got the FBA configured and working...

...BUT...I still do not get any of the Membership Requests to appear in the Manage Membership Requests list!!!

When using the FBA Pak's Membership Request web part...it adds the users to the database and assigns roles but does not activate or appear in the Review list.  I must be doing something wrong.  

Any suggestions?????

Coordinator
Oct 30, 2012 at 4:47 AM

Do you have 'Review Membership Requests' turned on in 'FBA Site Configuration'?

Is email setup on SharePoint, and does the requested user get an email that their membership is pending?  Email needs to be working for the FBA Pack to function.

Oct 30, 2012 at 11:52 AM

Thanks for the quick reply.  Yes I had Review Requests ON...but I had not yet setup out-going email!  I will assume that is the problem...and will update once I get it working.  

Nov 5, 2012 at 11:59 PM

Email on the server may be the problem on my new server...but on the Hosted environment, I do have working email..because SP can send emails when alerts are set up.

 

Coordinator
Nov 6, 2012 at 12:05 AM

Add a user with the membership request web part. After adding the user, check your SharePoint log files for errors.  Search for "FBA Pack" and you should see any errors the FBA Pack logged.