This project has moved. For the latest updates, please go here.

Enable-SPFeature Fails / Error Shown in Central Admin

Dec 20, 2011 at 7:56 PM

I'm able to get the solution to deploy to SharePoint 2010, but I get an error on the Enable-SPFeature command.

When I looked in Central Admin, I found the following.

Is there something I need to do to a manifest somewhere to get this to work? When I tried to deploy the solution in Cental Admin it blew up my site collection.

Central Administration -> Solution Properties

Name: visigo.sharepoint.formsbasedauthentication.wsp
Type: Core Solution
Contains Web Application Resource: Yes
Contains Global Assembly: Yes
Contains Code Access Security Policy: No
Deployment Server Type: Front-end Web server
Deployment Status: Error
Deployed To: None
Last Operation Result: Some of the files failed to copy during deployment of the solution.
Last Operation Details: Error: Cannot locate the <SafeControls> section in the web.config file for this site. Controls in the specified assembly cannot be marked as <SafeControls>.
Dec 20, 2011 at 9:02 PM

Here's the error I received in PowerShell:

Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url

Dec 21, 2011 at 3:29 AM

Can you check this thread:

If you can't get it working with the suggestions in there, post to the thread and ask if kpaquet ever resolved it.

Dec 21, 2011 at 2:50 PM

Thank you so much for your timely response.

I even tried other solutions and got the same error, so there is definitely something ate up with SharePoint, the web app, site collection, or all of the above.

I guess I just need to start by creating a new web app...and go from there.