Possible To Not Prompt Users After Opening Documents?

Aug 1, 2011 at 8:03 PM

Good Afternoon,

   Is it possible to make it so that users are not prompted after opening a document?  I have users that are complaining that they are prompted and do not like having to enter their password each time.  Is there a way around this?

Kind Regards,

Jerry

Coordinator
Aug 1, 2011 at 9:30 PM

Hi Jerry,

I haven't actually had that problem.  I can open a document no problem without being prompted for credentials.  My guess is that the user has their web page open say for 45 minutes, and the session expires - forcing them to login again on their next action (which in this case is opening a document).  I'd maybe try increasing the amount of time before the security validation expires (Central Admin -> Application Management -> General Settings).  There's a post about it here:

http://social.msdn.microsoft.com/Forums/eu/sharepoint2010general/thread/a2ee6db9-8fcb-4c9a-81e9-fd8238aad553

Also, thanks for the 5 star rating and the kind words in the other discussion. Much appreciated.

Aug 2, 2011 at 1:22 PM

Good Morning,

   Interesting . . . the odd thing is that I'm even getting this credential pop-up window when I navigate directly to the document library and open a document upon signing in.  The document library has restrictions on it based upon what group (edit or read-only) a user is part of, would this make a difference?

 

As for the 5 star rating and kind words, it is not a problem.  You deserve it, you not only have produced a great add-on but also provide stellar service and support.

Coordinator
Aug 2, 2011 at 1:30 PM

If they didn't have permissions, I guess I would expect they'd get an access denied message, not a login prompt.  Does it matter what type of document is opened? I've tried docx and pdf both with no problems.  Maybe try creating a brand new document library for testing, and see if you still have problems opening documents from that library. Another idea - make the fba user a site collection administrator and see if they still get the login prompt.

Aug 2, 2011 at 2:06 PM

All good approaches, though I'm not sure that they are good for me (this is usually the case it seems as I always wind up coming up with off-the-wall issues that need to be addressed LOL).  I am noticing it mostly on Office documents (e.g. Word, Excel), but not on PDFs.  I'm even seeing these prompts and I am a site collection administrator.  

Could they be any negative side-effects for turning off "Security Validation" in Web Application General Settings?  I think that if I turn that off then the users will not be prompted at all, though I'm concerned that there may be other ramifications . . . I just want to make sure that people only see what they are supposed to since I have libraries set up with restricted access (read-only, contribute, etc.).

Aug 2, 2011 at 3:24 PM

Hmm, well I've waited an hour after making that adjustment that I mentioned above and I'm still seeing the same behavior.  What I am proposing as a workaround for the time being to my users is that they click the "Automatically sign me in" checkbox and then the sign-in button . . . this will at least make it so that they are only prompted the first time during their login session . . . however, they will need to repeat this process every time that they login.  

Coordinator
Aug 2, 2011 at 3:45 PM

Yeah, i'm not sure about the security validation option.  I did have another idea though - hover over the hyperlink for the document and check where it's pointing,  Does the server portion of the url in the link match the url in your browser? I'm thinking that maybe you're accessing SharePoint using a url that hasn't been setup in SharePoint.

Aug 2, 2011 at 3:58 PM

I wish that were the case, however, unfortunately both URLs match.

I have at least one user that is really frustrated by having to input their credentials again for the second time during a session . . . and they are coming down on me.  I wish that we could resolve this; thank you for your continued assistance.

Coordinator
Aug 2, 2011 at 4:10 PM

Unfortunately I can't reproduce the problem here, so I don't think i'm going to be much help.  I'd probably try and see if you can reproduce it in another environment, and if you can't try and figure out the differences.  Otherwise, you may want to post in the MS SharePoint 2010 forums to see if anybody else is having the same issue, since I don't think the issue is related to the FBA Pack.  Another thought - do you have SP1 installed yet? I don't, but I remember reading something about a bug with security validation that was introduced in SP1.

Aug 2, 2011 at 4:33 PM

I sincerely appreciate your assistance.  I don't mean to take up so much of your time with this issue that I'm having.  

I haven't installed SP1 yet on this server, it sounds like that was a good choice from what you're telling me.

Sep 15, 2011 at 4:12 PM

Here is a nice post which fairly explains this scenario:

http://blogs.technet.com/b/steve_chen/archive/2010/06/25/multiple-logon-while-open-office-document-from-sharepoint.aspx

We've all been a slave to this authentication prompt issue - guess will have to wait for the next release of SharePoint or Office.

Hope this helps-
Sabs