This project has moved. For the latest updates, please go here.

Error 404 on custom forms.

Apr 27, 2011 at 6:53 PM

I am getting an error 404 when I try to use the FBA choices on Site Settings.  For instance, Choosing "FBA USer Management" gives me the URL

http://vmimssp2010dev:18340/_layouts/FBA/Management/UsersDisp.aspx

Which produces a 404 error.  This aspx file is where it ought to be, at: 

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS\FBA\MANAGEMENT\UsersDisp.aspx

And if I put a test empty aspx file in the same folder, I can browse to it, e.g. http://vmimssp2010dev:18340/_layouts/FBA/Management/test.aspx

I checked web.config, and the Visigo.Sharepoint.FormsBasedAuthentication assemply is marked as safe. 

What should I check next?  Thanks.

 

Coordinator
Apr 27, 2011 at 7:10 PM

The only thing I can think of off the top of my head is that for some reason the wrong permissions were assigned to the page when the WSP was deployed.  From explorer, check the properties on UserDisp.aspx and your test.aspx and see if there are any different permissions assigned. If it is a permission problem though, i'm not sure why the wrong permissions would be assigned.

I'd try redeploying the wsp, and also a server reboot, if you haven't already.

Apr 27, 2011 at 7:22 PM

I think I see it.  It's the code-behind files that are missing.  I have 8 aspx files in that folder and no cs files. 

<%@ Assembly Name="Visigo.Sharepoint.FormsBasedAuthentication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9dba9f460226d31d" %>

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="UsersDisp.aspx.cs" Inherits="Visigo.Sharepoint.FormsBasedAuthentication.UsersDisp"
    DynamicMasterPageFile="~masterurl/default.master" %>

Guess I better try a re-install.

 

 

Coordinator
Apr 27, 2011 at 7:26 PM

You actually won't find the codebehind files, as they're compiled into Visigo.Sharepoint.FormsBasedAuthentication.dll.  But yeah, try a redeploy + reboot and hopefully that fixes things up.

Apr 27, 2011 at 8:02 PM

I see what my problem is.  My Site Collection is not at the root of my web application.  My Web application is at

http://vmimssp2010dev:18340/

And my only current Site Collection is at:

http://vmimssp2010dev:18340/sites/FBATEst

I originally tried to deploy to http://vmimssp2010dev:18340/  but got errors because there is no site collection there.

Enable-SPFeature : The site http://vmimssp2010dev:18340/ could not be found in the Web application SPWebApplication Name=SP FBA Site - 18340. At E:\poulterhd\sharepoint2010fbapack\Deploy.ps1:44 char:17

I successfully deployed the feature to

http://vmimssp2010dev:18340/sites/FBATest  but my urls for the custom forms don't work.  The users form is not at

http://vmimssp2010dev:18340/_layouts/FBA/Management/UsersDisp.aspx

It is at:

http://vmimssp2010dev:18340/stes/FBATest/_layouts/FBA/Management/UsersDisp.aspx

But the link in Site Settings points to the first one.  when I change it to the second one, the form loads.

 

 

 

 

 

Coordinator
Apr 27, 2011 at 8:05 PM

Thanks for the heads up. I'll fix this in the next release.  

Coordinator
May 9, 2011 at 5:08 AM

Fixed in release 1.0.2